Results 1 to 13 of 13

Thread: SMS with Twilio

  1. #1
    Join Date
    Jun 2013
    Location
    Oklahoma
    Posts
    5

    SMS with Twilio

    Has anyone worked with Twilio? We are changing brokers and they seem to be pretty good from a cost perspective but just wondering how their platform and support rate.

    Thanks,

    Bill

  2. #2
    Join Date
    Nov 2006
    Location
    Anderson, IN
    Posts
    884

    Twilio...

    I've done some testing with them and am currently integrating them for a PureConnect/CIC solution. I've been impressed so far with their support, configuration options, and pricing.

  3. #3
    Join Date
    Dec 2011
    Location
    Arkansas
    Posts
    3
    Quote Originally Posted by dcurrier View Post
    I've done some testing with them and am currently integrating them for a PureConnect/CIC solution. I've been impressed so far with their support, configuration options, and pricing.
    Were you able to integrate with them using an XML mapping file in the i3sms folder?

  4. #4
    Join Date
    Nov 2006
    Location
    Anderson, IN
    Posts
    884

    SMS Broker Config

    The first time I did testing with Twilio, I had to manually create a new SMS Broker config (xml file, etc.). But in current versions of PureConnect/CIC, Twilio already has a Broker in place that just needs to be configured in Administrator. The most frustrating part of using SMS with CIC at the moment, is that there isn't a top-level media type for SMS yet. Well, there is IF you're just sending a one-off SMS message from the client. But if it is an inbound ACD SMS conversation, it's a sub-type of Chat and differs slightly based on how the inbound routing is configured.

  5. #5
    Join Date
    Dec 2011
    Location
    Arkansas
    Posts
    3
    We ended up getting the file from Genesys support and after a few tweaks we were able to get it working with our version. How would you say the experience has been working with Twilio?

  6. #6
    Join Date
    Nov 2006
    Location
    Anderson, IN
    Posts
    884

    Twilio

    Excellent.

  7. #7
    Join Date
    Aug 2015
    Posts
    1

    Not working here

    Hi,

    I just ran into this thread.

    As a matter of fact I have been trying to setup the Twilio broker with our test environment to test SMS conversations with customers.
    For inbound SMS no problem, but when I reply from within the interaction the SMS is not being sent back to Twilio.

    I have changed the MT URL to https and I have toggled between a basic and secure encryption.

    The logs show the following message HTTPS URI requested on an unsecure broker connection.

    I am stuck at this moment, so hopefully you guys have some tips I can try.

    Rgds,

    200_OK

  8. #8
    Join Date
    Nov 2006
    Location
    Anderson, IN
    Posts
    884

    Ssl

    I believe this message shows up when HTTPS is not enabled on the broker, but the outbound address is HTTPS. Twilio requires HTTPS for all API connections so it must be used. Due to how CIC handles certificates (and switchover), a reverse proxy server is needed at the edge of the environment to handle the connection to Twilio. See the SMS technical reference for details.

  9. #9
    Join Date
    Nov 2016
    Location
    Wisconsin
    Posts
    26
    Quote Originally Posted by dcurrier View Post
    I believe this message shows up when HTTPS is not enabled on the broker, but the outbound address is HTTPS. Twilio requires HTTPS for all API connections so it must be used. Due to how CIC handles certificates (and switchover), a reverse proxy server is needed at the edge of the environment to handle the connection to Twilio. See the SMS technical reference for details.

    We are currently in the testing phase with Twilio. I like the service.

    I'm having problems sending/receiving to anything except the default. Does anyone use this for purposes other than call center?

    Thanks!

  10. #10
    Join Date
    Nov 2006
    Location
    Anderson, IN
    Posts
    884

    routing

    The target for an inbound SMS message is determined by the routing rules. What are you trying to do?

  11. #11
    Join Date
    Nov 2016
    Location
    Wisconsin
    Posts
    26
    Quote Originally Posted by dcurrier View Post
    The target for an inbound SMS message is determined by the routing rules. What are you trying to do?
    I am trying to route to a user based on the DNIS.

    I have two text capable numbers, but it always follows the default. Doesn't matter which number I send an SMS to. It's probably something simple, but I haven't figured it out yet.

  12. #12
    Join Date
    Nov 2006
    Location
    Anderson, IN
    Posts
    884

    SMS inbound routing

    There are a couple of options for inbound routing to a user and a couple important considerations for routing.

    To configure SMS inbound routing:
    • Open Interaction Administrator, browse to System Configuration > SMS > Configuration > Inbound Routing tab
    • Click the Add... button to create a new routing entry
    • For simple routing, select DNIS from the Type dropdown
    • Enter the regular expression to match the full number to which the text is sent - Example: \+13172222222 (the backslash at the beginning of the regular expression allows the literal + character to be matched)
    • Select either Queue or Chat as the Destination - If Queue, then select the user queue to which the message should be delivered
    • If Chat, click OK to close the SMS configuration dialogs, then browse to System Configuration > Phone Numbers > Configuration > DID/DNIS tab
    • Click the Add... button to create a new DID/DNIS routing entry
    • Enter the full E.164 DNIS in the Simple Mapping field - Example: +13172222222
    • Select the appropriate user on the right side as the destination and click OK to save/close

  13. #13
    Join Date
    Nov 2016
    Location
    Wisconsin
    Posts
    26
    Quote Originally Posted by dcurrier View Post
    There are a couple of options for inbound routing to a user and a couple important considerations for routing.

    To configure SMS inbound routing:
    • Open Interaction Administrator, browse to System Configuration > SMS > Configuration > Inbound Routing tab
    • Click the Add... button to create a new routing entry
    • For simple routing, select DNIS from the Type dropdown
    • Enter the regular expression to match the full number to which the text is sent - Example: \+13172222222 (the backslash at the beginning of the regular expression allows the literal + character to be matched)
    • Select either Queue or Chat as the Destination - If Queue, then select the user queue to which the message should be delivered
    • If Chat, click OK to close the SMS configuration dialogs, then browse to System Configuration > Phone Numbers > Configuration > DID/DNIS tab
    • Click the Add... button to create a new DID/DNIS routing entry
    • Enter the full E.164 DNIS in the Simple Mapping field - Example: +13172222222
    • Select the appropriate user on the right side as the destination and click OK to save/close
    Thank you for the help! Each time I've gotten hung up on an SMS problem, I've been missing the '\'. All fixed!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •