Results 1 to 6 of 6

Thread: 2017 R3 Migrator Error

  1. #1
    Join Date
    Jul 2017
    Location
    St. Louis
    Posts
    27

    2017 R3 Migrator Error

    Hi All,

    seeing a strange issue with the new migrator. Our system is currently 2016 R4 Patch 5 which i used Migrator 2017 R3 to export configurations. I am then use Migrator 2017 R3 to import some of the configuration into my dev Enviorment:

    When it runs it stops with this error:

    " Error: Unsupported Version Migration, can only migrate forward in version"

    The configuration that it is stopping on are:
    Audio Sources
    Client Button
    Queue Columns Control
    Roles

    I compare the configuration between the 2 system on the configs the error pops on and they look identical; so my question is does migration compare the configuration and if identical not allow you to overwrite? or is there something else going on?

    Any insight would be appreciated.

    Thank you,
    Scott

  2. #2
    Join Date
    Oct 2002
    Location
    Indianapolis
    Posts
    2,044
    Scott,

    Just going by what you describe, not having tested anything, it sounds like Migrator thinks the version of IC in your test environment is older than the version of Migrator.

    What is the patch level on each?
    George Ganahl
    Principal Education Technology Consultant

  3. #3
    Join Date
    Jul 2017
    Location
    St. Louis
    Posts
    27
    That is what the Migrator Logs show, even though both are 2016 R4 patch 5. I3 has kicked this up to their Development team as even the INNProduct tool shows both version are the same.

    Thank you,
    Scott

  4. #4
    Join Date
    Oct 2002
    Location
    Indianapolis
    Posts
    2,044
    Both servers may be the same version, but you are trying to use the 2017 R3 version of Migrator to restore files to a 2016 R4 server. Won't work.
    George Ganahl
    Principal Education Technology Consultant

  5. #5
    Join Date
    Jul 2017
    Location
    St. Louis
    Posts
    27
    Hi George,

    I Originally thought that, but support says Migrator Version should not matter as they are backwards compatible.

    The underlying issue was that in the registry HKLM\Software\Wow6432Node\InteractiveIntelligence\ EIC\DirectoryServices\Root\CustomerSite\Production the Key VersionMajor was stating we were running 15, meaning 2015 when in fact we really were 16. Once we adjusted that Key to say 16 migrator ran successfully.


    Thank you,
    Scott

  6. #6
    Join Date
    Oct 2002
    Location
    Indianapolis
    Posts
    2,044
    By now, I should know better than to make a bold, definitive statement regarding what the product will or won't do.

    I'm glad you got it working!
    George Ganahl
    Principal Education Technology Consultant

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •